Help regarding developer kit

Aug 3, 2010 at 5:52 PM
I have Visual Studio Team System 2008 installed. But when I opened \source\Cosmos.sln file I got 3 three erros: a) http://lh3.ggpht.com/_geckbr7NrGA/TFhTPXINuTI/AAAAAAAAANU/E9Hw7fgNsPU/s400/error1.png b) http://lh4.ggpht.com/_geckbr7NrGA/TFhTazfYV5I/AAAAAAAAANc/qukjttpIcDc/s400/error2.jpg c) http://lh5.ggpht.com/_geckbr7NrGA/TFhTiYHf-yI/AAAAAAAAANk/UStGYmH01fg/s400/error3.jpg For error a, I clicked Yes, for error b, I clicked OK, for error c, I clicked OK. After all these errors, Solution Explorer shows 31 projects. now after closing Visual Studio I ran \Build\VSIP\install.bat 2 times. But every time after opening the Visual Studio I still get those 3 errors. Now I have two questions: 1) Are these errors normal and I don't have to worry about them? 2) Now for my personal modifications to the OS, what should I do? Where to put my code? What should be the startup project? (Well I'm looking to build GUI for Cosmos, a basic GUI including desktop, mouse pointer, icons, start menu. shutdown, restart etc)
Coordinator
Aug 3, 2010 at 5:56 PM
You dont have the Visual Studio SDK installed.
After you isntall the VSSDK version 1.1, (and Visual Studio SP1, but think you have that one) running install.bat should do the trick..

Be sure to install the InnoSetup QuickStart Pack


On Tue, Aug 3, 2010 at 7:52 PM, mobeen <notifications@codeplex.com> wrote:

From: mobeen

I have Visual Studio Team System 2008 installed. But when I opened \source\Cosmos.sln file I got 3 three erros: a) http://lh3.ggpht.com/_geckbr7NrGA/TFhTPXINuTI/AAAAAAAAANU/E9Hw7fgNsPU/s400/error1.png b) http://lh4.ggpht.com/_geckbr7NrGA/TFhTazfYV5I/AAAAAAAAANc/qukjttpIcDc/s400/error2.jpg c) http://lh5.ggpht.com/_geckbr7NrGA/TFhTiYHf-yI/AAAAAAAAANk/UStGYmH01fg/s400/error3.jpg For error a, I clicked Yes, for error b, I clicked OK, for error c, I clicked OK. After all these errors, Solution Explorer shows 31 projects. now after closing Visual Studio I ran \Build\VSIP\install.bat 2 times. But every time after opening the Visual Studio I still get those 3 errors. Now I have two questions: 1) Are these errors normal and I don't have to worry about them? 2) Now for my personal modifications to the OS, what should I do? Where to put my code? What should be the startup project? (Well I'm looking to build GUI for Cosmos, a basic GUI including desktop, mouse pointer, icons, start menu. shutdown, restart etc)

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Aug 3, 2010 at 8:09 PM
I downloaded SDK 1.1 from Microsoft's site, when I click on setup it prompted me that Microsoft Visual Studio 2008 or above should be installed on your computer. I reinstalled Team System but still the problem is there. If I switch to Visual Studio then the free available versions are Express Editions. Now tell me what to do? :(
Coordinator
Aug 3, 2010 at 9:03 PM

What do you mean by "switch to VS"? You said you already had VS Team System installed?

Coordinator
Aug 3, 2010 at 9:09 PM
Please ensure you have Visual Studio 2008 Service Pack 1 installed.
Starting to doubt that..

On 8/3/10, kudzu <notifications@codeplex.com> wrote:
> From: kudzu
>
> What do you mean by "switch to VS"? You said you already had VS Team System
> installed?
>
>
Aug 4, 2010 at 2:50 PM
OK. I have installed VS 2008 SP1, VSSDK 1.1 and Inno Setup Quick Start Pack. After all these steps and running the install.bat file, I again opened the source code, now solution explorer is showing 33 projects but after building the solution there is an error message :(... "Error 1 Could not load file or assembly 'Cosmos.Compiler.Debug, Version=1.0.0.0, Culture=neutral, PublicKeyToken=5ae71220097cb983' or one of its dependencies. The system cannot find the file specified. at Cosmos.IL2CPU.X86.DebugStub.Executing() at Cosmos.IL2CPU.X86.DebugStub.Emit() in c:\Users\Private\Downloads\Cosmos-64103\source2\IL2PCU\Cosmos.IL2CPU.X86\X86\SpecialDebug\DebugStub.cs:line 310 at Cosmos.IL2CPU.X86.DebugStub.Main(UInt16 aComAddr) in c:\Users\Private\Downloads\Cosmos-64103\source2\IL2PCU\Cosmos.IL2CPU.X86\X86\SpecialDebug\DebugStub.cs:line 486 at Cosmos.IL2CPU.X86.CosmosAssembler.Initialize() in c:\Users\Private\Downloads\Cosmos-64103\source2\IL2PCU\Cosmos.IL2CPU.X86\CosmosAssembler.cs:line 155 at Cosmos.Build.MSBuild.IL2CPU.Execute() in c:\Users\Private\Downloads\Cosmos-64103\source2\Build\Cosmos.Build.MSBuild\IL2CPU.cs:line 207 C:\Program Files (x86)\MSBuild\Cosmos\Cosmos.targets 46 10 Breakpoints"
Coordinator
Aug 4, 2010 at 2:53 PM
Please get the latest files from codeplex, there was a serious bug in install.bat.

On Wed, Aug 4, 2010 at 4:50 PM, mobeen <notifications@codeplex.com> wrote:

From: mobeen

OK. I have installed VS 2008 SP1, VSSDK 1.1 and Inno Setup Quick Start Pack. After all these steps and running the install.bat file, I again opened the source code, now solution explorer is showing 33 projects but after building the solution there is an error message :(... "Error 1 Could not load file or assembly 'Cosmos.Compiler.Debug, Version=1.0.0.0, Culture=neutral, PublicKeyToken=5ae71220097cb983' or one of its dependencies. The system cannot find the file specified. at Cosmos.IL2CPU.X86.DebugStub.Executing() at Cosmos.IL2CPU.X86.DebugStub.Emit() in c:\Users\Private\Downloads\Cosmos-64103\source2\IL2PCU\Cosmos.IL2CPU.X86\X86\SpecialDebug\DebugStub.cs:line 310 at Cosmos.IL2CPU.X86.DebugStub.Main(UInt16 aComAddr) in c:\Users\Private\Downloads\Cosmos-64103\source2\IL2PCU\Cosmos.IL2CPU.X86\X86\SpecialDebug\DebugStub.cs:line 486 at Cosmos.IL2CPU.X86.CosmosAssembler.Initialize() in c:\Users\Private\Downloads\Cosmos-64103\source2\IL2PCU\Cosmos.IL2CPU.X86\CosmosAssembler.cs:line 155 at Cosmos.Build.MSBuild.IL2CPU.Execute() in c:\Users\Private\Downloads\Cosmos-64103\source2\Build\Cosmos.Build.MSBuild\IL2CPU.cs:line 207 C:\Program Files (x86)\MSBuild\Cosmos\Cosmos.targets 46 10 Breakpoints"

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Aug 4, 2010 at 4:48 PM
Thanks for resolving my problem #1. Now for my problem #2 i.e. GUI. So can you give me some starting hints: 2a) Where to write my code and use the commands like Cosmos.Hardware etc? 2b) What should be selected as startup project? 2c) Give me the idea that how to hide Console and bring some graphics? I know the last question is silly one but just give me the clue and I'll try the rest for my own :)
Aug 5, 2010 at 9:12 AM
Anyone?
Coordinator
Aug 5, 2010 at 11:41 AM
Please dont' be so rude to expect chat-like response times in a forum.


If you want chat, use our chat (irc)

I've never used graphics, so you'll need someone else to respond.



On Thu, Aug 5, 2010 at 1:26 PM, mobeen <notifications@codeplex.com> wrote:

From: mobeen

Anyone?

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Aug 5, 2010 at 12:42 PM
OK I'll consult there too :) Sorry for being rude. If you get time, then just tell me that how to set up developer kit and how to add a project?
Aug 10, 2010 at 1:55 PM

Getting this error: The type or namespace name 'Compiler' does not exist in the namespace 'Cosmos' (are you missing an assembly reference?) C:\Users\Private\Downloads\Cosmos-Latest\source\CosmosBoot1\Program.cs 2 14 CosmosBoot1.......... tried everything but not getting rid of this error.

Intalled: Visual Studio Team Suite 2008. Visual Studio 2008 Service Pack 1. VS SDK 1.1. IS QS Pack. Cosmos User Kit MS5. (and opening the dev kit after running install.bat 2 time with admin privileges.

 

Coordinator
Aug 10, 2010 at 2:01 PM
Sounds like some serious leftovers. Please remove MS5 first, then rerun install.bat as admin.
Then try to create new project. and see if it works..


On Tue, Aug 10, 2010 at 3:56 PM, mobeen <notifications@codeplex.com> wrote:

From: mobeen

Getting this error: The type or namespace name 'Compiler' does not exist in the namespace 'Cosmos' (are you missing an assembly reference?) C:\Users\Private\Downloads\Cosmos-Latest\source\CosmosBoot1\Program.cs 2 14 CosmosBoot1.......... tried everything but not getting rid of this error.

Intalled: Visual Studio Team Suite 2008. Visual Studio 2008 Service Pack 1. VS SDK 1.1. IS QS Pack. Cosmos User Kit MS5. (and opening the dev kit after running install.bat 2 time with admin privileges.

 

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Aug 11, 2010 at 11:05 PM
Now I'm constantly getting this error : No Kernel.Boot method found! What the heck is wrong now?? :-S
Coordinator
Aug 12, 2010 at 8:07 AM
Are you on cosmos-dev mailinglist? Over there, i'm now posting a message on the latest devkit changes (Forgot to send there).

You need to remove all the code from your .Cosmos project, and put it in a classlibrary. From the .Cosmos project, you reference the classlibrary. The classlibrary should contain a public class Kernel, which contains a public static void Boot()

On Thu, Aug 12, 2010 at 1:05 AM, mobeen <notifications@codeplex.com> wrote:

From: mobeen

Now I'm constantly getting this error : No Kernel.Boot method found! What the heck is wrong now?? :-S

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com