Broken References?

Developer
May 27, 2011 at 3:30 PM

I tried to run guess using build 78322. I get this when trying to run it:
http://tinypic.com/r/10shpqs/7
Then I tried to look at the references
http://tinypic.com/r/jpewib/7

Currently using Visual Studio 2010 Ultimate on Windows 7 x64

Coordinator
May 27, 2011 at 3:35 PM
The References thingy is a bug in cosmos, but it'll normally work. regarding the compiler error, try to remove the using statment and see if it works..

On Fri, May 27, 2011 at 5:30 PM, grygrflzr <notifications@codeplex.com> wrote:

From: grygrflzr

I tried to run guess using build 78322. I get this when trying to run it:
http://tinypic.com/r/10shpqs/7
Then I tried to look at the references
http://tinypic.com/r/jpewib/7

Currently using Visual Studio 2010 Ultimate on Windows 7 x64

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Developer
May 28, 2011 at 10:52 AM
Edited May 28, 2011 at 10:53 AM

Bleh, I tried re-adding the broken references and no errors...
Except that everything I run (Guess Demo, BreakpointsKernel, Matthijs Playground, Cosmos.Assembler.X86.Gero) gives me this:
http://i53.tinypic.com/14l80ew.png

Btw, and everytime I open Cosmos (always in Admin mode) I get:
'<cosmosDir>\Latest\source2\Users\Kudzu\Breakpoints\Breakpoint.Cosmos' cannot be opened because its project type (.Cosmos) is not supported by this version of the application.
And the same for '<cosmosDir>\Latest\source2\Demos\Guess\Guess.Cosmos' and '<cosmosDir>\Latest\source2\Users\Matthijs\MatthijsPlayground\MatthijsPlaygroundBoot.Cosmos'.

Then I get:
One or more projects in the solution were not loaded correctly.
Please see the Output Window for details.

In the output window:
C:\Users\GrygrFlzr\Projects\Cosmos\Latest\source2\VSIP\Cosmos.VS.Package\Cosmos.VS.Package.csproj : error  : Unable to read the project file 'Cosmos.VS.Package.csproj'.
C:\Users\GrygrFlzr\Projects\Cosmos\Latest\source2\VSIP\Cosmos.VS.Package\Cosmos.VS.Package.csproj(324,3): The imported project "C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v10.0\VSSDK\Microsoft.VsSDK.targets" was not found. Confirm that the path in the <Import> declaration is correct, and that the file exists on disk.

Do I need to install anything extra? I just recently installed VS 2010. I previously used VS 2008 to open my outdated version :P

Developer
May 28, 2011 at 4:11 PM
Edited May 28, 2011 at 4:15 PM

yes, you need to download and install the Visual Studio SDK as well, that will fix the second problem. The first problem might be due to cosmos's installer installing to the lowest available version (does it actually do this?)

 I haven't checked which version cosmos support got added to when I installed to my debug vm (it has an absurd amount of programs on it, with various conflicts, which I've done delebrately so-as to be able to test things in very unusual circumstances.) It has vs2005, 2008, and 2010 installed, and when I built the dev-kit in it, it didn't install to vs2010, and I haven't bothered to search through the versions to see which one it installed to. Also, having 2005 installed doesn't cause any problems, as my main dev machine has 2005 installed as well.

 

(btw, why does the vsix package that the devkit creates allow you to try to install is to C++ 2010 Express, when that won't actually work?)

Coordinator
May 28, 2011 at 8:37 PM

quote:

 why does the vsix package that the devkit creates allow you to try to install is to C++ 2010 Express, when that won't actually work?)

 

It is  only a hoe in a checkbox that that allow it. It is also the Web edition accepted.

Coordinator
May 29, 2011 at 6:37 AM
Checkbox?

We explicitly install to C# express and VB Expres only and the full versions, that is.

It just seems to me he doesn't have the InnoSetup QuickStart Pack installed. AFter that he needs to run the install.bat

On Sat, May 28, 2011 at 10:38 PM, Trivalik <notifications@codeplex.com> wrote:

From: Trivalik

quote:

why does the vsix package that the devkit creates allow you to try to install is to C++ 2010 Express, when that won't actually work?)

It is only a hoe in a checkbox that that allow it. It is also the Web edition accepted.

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Developer
May 30, 2011 at 11:22 AM

I have installed Visual Studio SDK and InnoSetup QuickStart Pack. :P
Then I ran install.bat (from <cosmosLocation>\Build\VSIP (is that the correct one?)
I'm still getting the 'output with project type cannot be started directly' error... :(

Coordinator
May 30, 2011 at 11:30 AM
Then you're doing it wrong. You should have 2 projects, a .csproj one which compiles into a library, and a .cosmos project, which you should run. The latter is just a meta project, allowing us to use the visual studio built-in intellisense, but also leverage our compiler and debugger facilities..

On Mon, May 30, 2011 at 1:22 PM, grygrflzr <notifications@codeplex.com> wrote:

From: grygrflzr

I have installed Visual Studio SDK and InnoSetup QuickStart Pack. :P
Then I ran install.bat (from <cosmosLocation>\Build\VSIP (is that the correct one?)
I'm still getting the 'output with project type cannot be started directly' error... :(

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Developer
May 31, 2011 at 1:07 PM

Alright, now I'm running the .cosmos one and I'm getting this:
http://i54.tinypic.com/2hyiiiq.png
Darnit?

Coordinator
May 31, 2011 at 1:17 PM
If you build the solution, do you get any issues? Also, what project are you building? By any chance a custom project inside the cosmos solution?
Please check the solution configuration. This error is the one you get when (besides some other issues) the project isn't getting built...


On Tue, May 31, 2011 at 3:07 PM, grygrflzr <notifications@codeplex.com> wrote:

From: grygrflzr

Alright, now I'm running the .cosmos one and I'm getting this:
http://i54.tinypic.com/2hyiiiq.png
Darnit?

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Developer
May 31, 2011 at 1:28 PM

I'm always running the Guess Demo. No point on creating a new project if even the Demo doesn't work. :P
And no build errors. Whether it's the .csproj one or the .cosmos one...
GAAAAAAAAAAAAAAAH! >:(

Coordinator
May 31, 2011 at 1:48 PM
Please see the solution configuration, and verify that the project you're trying to run is being set to build. (To see if it's this, force-build the project by right-clicking it..)


On Tue, May 31, 2011 at 3:28 PM, grygrflzr <notifications@codeplex.com> wrote:

From: grygrflzr

I'm always running the Guess Demo. No point on creating a new project if even the Demo doesn't work. :P
And no build errors. Whether it's the .csproj one or the .cosmos one...
GAAAAAAAAAAAAAAAH! >:(

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Developer
May 31, 2011 at 10:54 PM

btw, just a small bug note, .cosmos project files don't build unless you have them set as the startup project. (at least not via the build command, they might build with the re-build command)

Developer
Jun 1, 2011 at 5:07 AM

Eh, I always use the right-click build :(
And rebuilding causes no errors.

Coordinator
Jun 1, 2011 at 7:24 AM
Blah: that's a feature, not a bug. ;-)

Seriously: the Cosmos.sln solution will contain multiple .Cosmos files. We dont want it to rebuild ALL .cosmos projects all the time, just the one we're working on (and have specified as startup project)

On Wed, Jun 1, 2011 at 7:07 AM, grygrflzr <notifications@codeplex.com> wrote:

From: grygrflzr

Eh, I always use the right-click build :(
And rebuilding causes no errors.

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com