Boot error.

Jun 14, 2012 at 5:07 AM

I just installed Cosmos and when I start a new project using the template, I get an error with the

Cosmos.Kernel.Boot.Default();

line.  I don't get why I would be getting this error, because I have not edited anything at all.  The error says

Error 2 The type or namespace name 'Boot' does not exist in the namespace 'Cosmos.Kernel' (are you missing an assembly reference?)

Thanks, Dean.

Coordinator
Jun 14, 2012 at 7:55 AM
What version of cosmos are you using?
Also, what Visual studio edition(s) you have?

On Thu, Jun 14, 2012 at 6:08 AM, repulverized <notifications@codeplex.com> wrote:

From: repulverized

I just installed Cosmos and when I start a new project using the template, I get an error with the

Cosmos.Kernel.Boot.Default();

line. I don't get why I would be getting this error, because I have not edited anything at all. The error says

Error 2 The type or namespace name 'Boot' does not exist in the namespace 'Cosmos.Kernel' (are you missing an assembly reference?)

Thanks, Dean.

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Jun 14, 2012 at 4:04 PM

I have the newest version of cosmos (87612).  

I have VS 2008, VC# 2010 express, and VB 2010 express.  I was using visual c# 2010 express when I got this error.

Thanks, Dean.

Jun 15, 2012 at 2:08 AM

Use cosmos c# library. Then press F6 to build it, and then go to the shell, and add a reference in the cosmos c# library/name/Bin/Debug/name.dll. name is the project name. Hope this helps.

Coordinator
Jun 15, 2012 at 8:04 AM
The line you get an error on doesn't sound like usable for the latest release...


On Fri, Jun 15, 2012 at 3:08 AM, jpal <notifications@codeplex.com> wrote:

From: jpal

Use cosmos c# library. Then press F6 to build it, and then go to the shell, and add a reference in the cosmos c# library/name/Bin/Debug/name.dll. name is the project name. Hope this helps.

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Jun 15, 2012 at 1:32 PM

Then could you please post the template for the latest release?

Coordinator
Jun 15, 2012 at 1:46 PM
Is this using a cleanly created project from the template?
Did you have an old (MS4 or older i think) version of cosmos installed before?
(also in VS2008)


On Fri, Jun 15, 2012 at 2:32 PM, repulverized <notifications@codeplex.com> wrote:

From: repulverized

Then could you please post the template for the latest release?

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Jun 15, 2012 at 2:52 PM

Actually I did have MS1 installed a while ago.  I tried to get rid of anything that had to do with cosmos before I installed the newest version.

Coordinator
Jun 15, 2012 at 2:58 PM
Sounds like some old stuff interfering..

On Fri, Jun 15, 2012 at 3:52 PM, repulverized <notifications@codeplex.com> wrote:

From: repulverized

Actually I did have MS1 installed a while ago. I tried to get rid of anything that had to do with cosmos before I installed the newest version.

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com