Great Error!

Topics: Compiler, Using Cosmos (Developing your own OS, projects, etc)
Sep 7, 2013 at 9:24 AM
I am using the latest release of Cosmos and this is what I get when I create a new Project in VS 2010 Shell
The file C:\Program Files\Microsoft Visual Studio 2010\Common7\IDE\TemplatesCahce\Cosmos.zip\CosmosProject.Cosmos could not be found!
And one more :
The file Cosmos.bxrc could not be found. The resulting project will continue to run but may not build properly
Sep 7, 2013 at 11:25 AM
I myself solved it!
Coordinator
Sep 7, 2013 at 12:21 PM

Care to explain how?

Op 7 sep. 2013 13:26 schreef "ALLDESP" <[email removed]> het volgende:

From: ALLDESP

I myself solved it!

Read the full discussion online.

To add a post to this discussion, reply to this email ([email removed])

To start a new discussion for this project, email [email removed]

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Sep 7, 2013 at 1:02 PM
Edited Sep 7, 2013 at 1:07 PM
Ok so here I explain :
First goto your C:\Program Files\MSBuild <Or whatever>
Then in the Cosmos.target file see that shitty line that contains Cosmos.bxrc (Open with Notepad or any texteditor) (I think it's in the last of the file)
Delete that....
Then goto your C:\Program Files\Microsoft Visual Studio 10.0\Common7\IDE\ProjectTemplatesCache\Cosmos.zip and create a new file called CosmosProject.Cosmos
Add this using a text editor :
http://pastebin.com/rjU0XyNn
You will need to then create a cosmos project it,
Note : I have added a Dll there so you will delete it in the VS Shell and then generate a Template by File>Export Template
Sorry I if this is poorly explained, I will try to make a youtube video on this...