problem with compiling cosmos svn

Jul 28, 2010 at 5:07 PM
i have vs2008 and vs2010 but iwhen i compiles it runing the buildall.bat file in the source2 folder i took the following errors: "F:\My Programs\dotNet\Testing Releases\Patato OS\Patato OS\Cosmos Os Kernel\source\Cosmos.sln" (default target) (1) -> (Build target) -> F:\My Programs\dotNet\Testing Releases\Patato OS\Patato OS\Cosmos Os Kernel\source2\Users\Kudzu\Breakpoints\Breakpoints.Cosmos(65,11): error MSB4019: The imported project "C:\Program Files (x86)\MSBuild\Cosmos\Cosmos.targets" was not found. Confirm that the path in the <Import> declaration is correct, and that the file exists on disk. F:\My Programs\dotNet\Testing Releases\Patato OS\Patato OS\Cosmos Os Kernel\source2\VSIP\Cosmos.VS.Package\Cosmos.VS.Package.csproj(278,11): error MSB4019: The imported project "C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v9.0\VSSDK\Microsoft.VsSDK.targets" was not found. Confirm that the path in the <Import> declaration is correct, and that the file exists on disk. 0 Warning(s) 2 Error(s) how i fix them
Jul 28, 2010 at 5:22 PM
also in vs2008 pro when i press to compile the relese configuration it show this error Error 10 The name 'xNeedsGC' does not exist in the current context F:\My Programs\dotNet\Testing Releases\Patato OS\Patato OS\Cosmos Os Kernel\source2\IL2PCU\Cosmos.IL2CPU.X86\IL\Ldfld.cs 116 15 Cosmos.IL2CPU.X86
Coordinator
Jul 28, 2010 at 8:56 PM
you need to install the visual studio sdk (2008 / 1.1 ) to install the devkit.

from the first message, the first message is weird. are you sure
you're using the latest ?

building release configuration is never used, so not working.

On 7/28/10, angarato_surion <notifications@codeplex.com> wrote:
> From: angarato_surion
>
> also in vs2008 pro when i press to compile the relese configuration it
> show this errorError 10 The name 'xNeedsGC' does not exist in the current
> context F:\My Programs\dotNet\Testing Releases\Patato OS\Patato OS\Cosmos Os
> Kernel\source2\IL2PCU\Cosmos.IL2CPU.X86\IL\Ldfld.cs 116 15 Cosmos.IL2CPU.X86
>
>
>
Jul 28, 2010 at 9:13 PM

ssource code yes  i download it today

also what configuration to use to work ?

 

Coordinator
Jul 29, 2010 at 4:25 PM
to install, running build/vsip/install.bat should work. to open
solution, use debug|x86 configuration

On 7/28/10, angarato_surion <notifications@codeplex.com> wrote:
> From: angarato_surion
>
> ssource code yes i download it todayalso what configuration to use to work
> ?
>
>