This project is read-only.

Missing Reference

Aug 11, 2010 at 10:53 AM
After Running Install From Devkit i created a test cosmos project, but it wont compile, because of missing reference I created an issue http://cosmos.codeplex.com/workitem/11737 using System; using Cosmos.Compiler.Builder; <-- This Reference is Missing namespace test1 { class Program { #region Cosmos Builder logic // Most users wont touch this. This will call the Cosmos Build tool [STAThread] static void Main(string[] args) { BuildUI.Run(); } #endregion // Main entry point of the kernel public static void Init() { var xBoot = new Cosmos.Sys.Boot(); xBoot.Execute(); Console.WriteLine("Welcome! You just booted C# code. Please edit Program.cs to fit your needs"); while (true) ; } } }
Aug 11, 2010 at 10:55 AM
UserKit MS5 needs you to create a new project, as our build strategy changed severely. Please create a new Cosmos project, and copy your sources.

On Wed, Aug 11, 2010 at 11:53 AM, CravingPine <notifications@codeplex.com> wrote:

From: CravingPine

After Running Install From Devkit i created a test cosmos project, but it wont compile, because of missing reference I created an issue http://cosmos.codeplex.com/workitem/11737 using System; using Cosmos.Compiler.Builder; <-- This Reference is Missing namespace test1 { class Program { #region Cosmos Builder logic // Most users wont touch this. This will call the Cosmos Build tool [STAThread] static void Main(string[] args) { BuildUI.Run(); } #endregion // Main entry point of the kernel public static void Init() { var xBoot = new Cosmos.Sys.Boot(); xBoot.Execute(); Console.WriteLine("Welcome! You just booted C# code. Please edit Program.cs to fit your needs"); while (true) ; } } }

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Aug 11, 2010 at 11:08 AM
It Appears in Documents\Visual Studio 2008\Templates\ProjectTemplates The CosmosBoot From M4 was still there. i manually removed it and used Cosmos Project, now it works
Aug 11, 2010 at 11:08 AM
It Appears in Documents\Visual Studio 2008\Templates\ProjectTemplates The CosmosBoot From M4 was still there. i manually removed it and used Cosmos Project, now it works