Getting cosmos to work = living hell

Apr 22, 2011 at 9:03 PM

I have VC# 2010 Express, Visual Studio Shell, and the latest Cosmos User Kit installed.

First thing I tried to do was add the boot commands (Cosmos.Sys.Boot), following a tutorial - but VC says it doesn't exist. I imported all of the DLLs in the cosmos folder to see if it would still work, but no dice. I decided to use the code that was there already and build it just to test it out.

So I built it, and guess what. "A project with an Output Type of Class Library cannot be started directly." I read a few posts here and it turns out that I have to build it using Visual Studio Shell. So, I put the .cs file into VSS and built it. It failed to compile, and there were no errors. Compile log:

------ Build started: Project: Cosmos1, Configuration: Debug x86 ------
Done building project "Cosmos1.Cosmos" -- FAILED.

Build FAILED.
========== Build: 0 succeeded or up-to-date, 1 failed, 0 skipped ==========

So I read some more. Turns out I had to use the .dll compiled in VC as a reference in VS Shell. So, I did, and here's what happens:

------ Build started: Project: Cosmos1, Configuration: Debug x86 ------
C:\Windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.Common.targets(1360,9): warning MSB3245: Could not resolve this reference. Could not locate the assembly "CSharpKernel1, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null". Check to make sure the assembly exists on disk. If this reference is required by your code, you may get compilation errors.
Done building project "Cosmos1.Cosmos" -- FAILED.

========== Build: 0 succeeded or up-to-date, 1 failed, 0 skipped ==========

How could it not locate the assembly? I added it to the project and it's still not recognizing it.

Cosmos seems pretty broken to me. I've tried older versions of Cosmos but I still have the same problem.

Coordinator
Apr 23, 2011 at 9:43 AM
You're using wrong tutorial.....

in VCS Express, you make a .dll (CSHarpKernel1.dll), which you reference from the Shell project. in the Shell you hit F5, and it'll run

On Fri, Apr 22, 2011 at 10:03 PM, canadianpenguin <notifications@codeplex.com> wrote:

From: canadianpenguin

I have VC# 2010 Express, Visual Studio Shell, and the latest Cosmos User Kit installed.

First thing I tried to do was add the boot commands (Cosmos.Sys.Boot), following a tutorial - but VC says it doesn't exist. I imported all of the DLLs in the cosmos folder to see if it would still work, but no dice. I decided to use the code that was there already and build it just to test it out.

So I built it, and guess what. "A project with an Output Type of Class Library cannot be started directly." I read a few posts here and it turns out that I have to build it using Visual Studio Shell. So, I put the .cs file into VSS and built it. It failed to compile, and there were no errors. Compile log:

------ Build started: Project: Cosmos1, Configuration: Debug x86 ------
Done building project "Cosmos1.Cosmos" -- FAILED.

Build FAILED.
========== Build: 0 succeeded or up-to-date, 1 failed, 0 skipped ==========

So I read some more. Turns out I had to use the .dll compiled in VC as a reference in VS Shell. So, I did, and here's what happens:

------ Build started: Project: Cosmos1, Configuration: Debug x86 ------
C:\Windows\Microsoft.NET\Framework\v4.0.30319\Microsoft.Common.targets(1360,9): warning MSB3245: Could not resolve this reference. Could not locate the assembly "CSharpKernel1, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null". Check to make sure the assembly exists on disk. If this reference is required by your code, you may get compilation errors.
Done building project "Cosmos1.Cosmos" -- FAILED.

========== Build: 0 succeeded or up-to-date, 1 failed, 0 skipped ==========

How could it not locate the assembly? I added it to the project and it's still not recognizing it.

Cosmos seems pretty broken to me. I've tried older versions of Cosmos but I still have the same problem.

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Apr 24, 2011 at 11:23 PM

I did that. Please read my posts before replying.

Coordinator
Apr 25, 2011 at 2:07 PM
Please try rebuilding the C# Express solution, and then re-adding the reference to the .cosmos project. then rebuild that project..


On Mon, Apr 25, 2011 at 12:23 AM, canadianpenguin <notifications@codeplex.com> wrote:

From: canadianpenguin

I did that. Please read my posts before replying.

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com