Floppy Driver

Jul 19, 2011 at 2:15 AM

Hello. Has anyone made a floppy  driver for cosmos yet? If not, or nobody wants to give away the source, could anyone point me in the right direction for making one (i understand its very hard, but i like challenges)?

Coordinator
Jul 19, 2011 at 2:17 AM
> Hello. Has anyone made a floppy driver for cosmos yet? If not, or nobody
> wants to give away the source, could anyone point me in the right
> direction for making one (i understand its very hard, but i like
> challenges)?

wiki.osdev.org

Why floppy though?
Jul 19, 2011 at 2:20 AM

Ill try that.

I don't know, i don't need much space, just want to store settings and notes. Though a HDD driver would be much nicer!

Coordinator
Jul 19, 2011 at 2:23 AM
> I don't know, i don't need much space, just want to store settings and
> notes. Though a HDD driver would be much nicer!

HD is already mostly working. Its blocked by some compiler bugs which we
are working on now.
Jul 19, 2011 at 2:37 AM

Do you have an estimated amount of time it will take?

Coordinator
Jul 19, 2011 at 2:47 AM
> Do you have an estimated amount of time it will take?

A few weeks maybe. You can look at my playground, it already reads files.
Jul 19, 2011 at 3:55 AM

Is it the BreakpointsKernel? If not, i cant find it.

Coordinator
Jul 19, 2011 at 3:57 AM
> Is it the BreakpointsKernel? If not, i cant find it.

Yes. But you have to comment out the NullableTest, it crashes currently.
Jul 19, 2011 at 4:20 AM

I have a 'Modified' UserKit, it has all of the things in ms5 i think, but it doesn't work, i tried copying TestATA() function to my OS. Do you need to use the devkit?

Coordinator
Jul 19, 2011 at 4:21 AM
> I have a 'Modified' UserKit, it has all of the things in ms5 i think,
> but it doesn't work, i tried copying TestATA() function to my OS. Do you
> need to use the devkit?

Yes, you need dev kit. MS5 is pretty old.
Jul 19, 2011 at 4:23 AM

Oh, every time i try to build the dev kit, it fails.

Jul 19, 2011 at 4:41 AM

And also, how would one go about using the Sound Card? I see some things in Hardware.Sound, but it seems confusing...

Jul 19, 2011 at 5:59 AM
kudzu wrote:
> Do you have an estimated amount of time it will take?

A few weeks maybe. You can look at my playground, it already reads files.

Not to highjack this thread but how do I look at your playground. Thanks Kudzu - Matt And A Few Weeks! So cool! That is awesome guys. If it takes longer thats fine, im just happy to have Cosmos

Coordinator
Jul 19, 2011 at 6:35 AM
regarding issues with building devkit: just ask a question here or on the mailinglist, telling what you did (what you have installed, vs edition, etc), what you expected to happen, and what happens (including full text of error messages), and we'll do our best to help you out..


On Tue, Jul 19, 2011 at 7:59 AM, civilwarrock <notifications@codeplex.com> wrote:

From: civilwarrock

kudzu wrote:
> Do you have an estimated amount of time it will take?

A few weeks maybe. You can look at my playground, it already reads files.

Not to highjack this thread but how do I look at your playground. Thanks Kudzu - Matt And A Few Weeks! So cool! That is awesome guys. If it takes longer thats fine, im just happy to have Cosmos

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Jul 19, 2011 at 7:19 AM
mterwoord wrote:
regarding issues with building devkit: just ask a question here or on the mailinglist, telling what you did (what you have installed, vs edition, etc), what you expected to happen, and what happens (including full text of error messages), and we'll do our best to help you out..


On Tue, Jul 19, 2011 at 7:59 AM, civilwarrock <notifications@codeplex.com> wrote:

From: civilwarrock

kudzu wrote:
> Do you have an estimated amount of time it will take?

A few weeks maybe. You can look at my playground, it already reads files.

Not to highjack this thread but how do I look at your playground. Thanks Kudzu - Matt And A Few Weeks! So cool! That is awesome guys. If it takes longer thats fine, im just happy to have Cosmos

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


oh ok thanks mterwoord. Thanks - Matt

Jul 19, 2011 at 2:56 PM
mterwoord wrote:
regarding issues with building devkit: just ask a question here or on the mailinglist, telling what you did (what you have installed, vs edition, etc), what you expected to happen, and what happens (including full text of error messages), and we'll do our best to help you out..

Its been a while since i tried, whitch folder is the build dir?

and i have vc# 2008 (Currently using for cosmos) 2010 with (i forgot what it was called, the visual studio console or whatever) and visual studio with c#.

Coordinator
Jul 19, 2011 at 3:02 PM
for devkit, you need VS2010 (Std or up), VS SDK installed, Innosetup quick start pack. After that, just run Build\VSIP\Install.bat, and it should install everything for you.

Dont forget to first uninstall all previous versions of cosmos userkit

On Tue, Jul 19, 2011 at 4:56 PM, farlepet <notifications@codeplex.com> wrote:

From: farlepet

mterwoord wrote:
regarding issues with building devkit: just ask a question here or on the mailinglist, telling what you did (what you have installed, vs edition, etc), what you expected to happen, and what happens (including full text of error messages), and we'll do our best to help you out..

Its been a while since i tried, whitch folder is the build dir?

and i have vc# 2008 (Currently using for cosmos) 2010 with (i forgot what it was called, the visual studio console or whatever) and visual studio with c#.

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Jul 19, 2011 at 3:19 PM

I forgot to install the sdk i guess, now VS2010 is asking me for credentials for tfs.cosmos.com/tfs/tfs04 Do i need to give some password and username here?

Coordinator
Jul 19, 2011 at 3:25 PM
you can skip it for now. but you did the install.bat thing? at the end it starts vs automatically. have a look at the commandprompt, and look for errors.
After that, (and with absence of errors in output) devkit is installed, and functions as if it were a userkit.

On Tue, Jul 19, 2011 at 5:19 PM, farlepet <notifications@codeplex.com> wrote:

From: farlepet

I forgot to install the sdk i guess, now VS2010 is asking me for credentials for tfs.cosmos.com/tfs/tfs04 Do i need to give some password and username here?

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Coordinator
Jul 19, 2011 at 3:25 PM
And for further questions, please start a new thread..

On Tue, Jul 19, 2011 at 5:24 PM, Matthijs ter Woord <matthijsterwoord@gmail.com> wrote:
you can skip it for now. but you did the install.bat thing? at the end it starts vs automatically. have a look at the commandprompt, and look for errors.
After that, (and with absence of errors in output) devkit is installed, and functions as if it were a userkit.


On Tue, Jul 19, 2011 at 5:19 PM, farlepet <notifications@codeplex.com> wrote:

From: farlepet

I forgot to install the sdk i guess, now VS2010 is asking me for credentials for tfs.cosmos.com/tfs/tfs04 Do i need to give some password and username here?

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com



Jul 19, 2011 at 3:27 PM

Okay, thanks for the  help, if i have any more devkit questions ill start a new thread.