Colors?

Sep 28, 2011 at 10:29 PM
Edited Sep 28, 2011 at 10:37 PM

Hey Guys I built that Image convertor CAIC. But I noticed I had a image with green in it and when I run the code It produced the colors were purple and not the original. Is there anyway to make it so the colors that where in the image are the same? Do I need to play with ARGB in the OS or is it like the Hue or Lum or Sat.  Thanks - Mat

Edit: Hahaha lol I forgot to say I use MS4. Lol

Sep 28, 2011 at 11:16 PM
It is because your caic uses a different colour codes then people's os btw I think the VGA.plattae has something to do with it.

_____________________
Jacksen

On 29/09/2011, at 8:29 AM, "civilwarrock" <notifications@codeplex.com> wrote:

From: civilwarrock

Hey Guys I built that Image convertor CAIC. But I noticed I had a image with green in it and when I run the code It produced the colors were purple and not the original. Is there anyway to make it so the colors that where in the image are the same? Do I need to play with ARGB in the OS or is it like the Hue or Lum or Sat. Thanks - Matt

Sep 28, 2011 at 11:38 PM

Well CAIC uses RGB values, I took a green color from a image and tried to display it in my os and it turned pink. So is there a way to prevent that from happening? Do I need to convert the color values to something? Thanks - Matt

Sep 29, 2011 at 12:33 AM

Ok well I tested some things and I saw how others use the colors, so I converted the green color to hex. But its still pink! Can I fix this? Thanks - Matt

 

VGAScreen.SetPaletteEntry(1, 0x7C, 0xD6, 0x56); //Green

Sep 29, 2011 at 12:54 AM
Edited Sep 29, 2011 at 1:32 AM

Edit Scratch That! Never mind that does not work for all the colors! Anyway does anybody know how to fix this in MS4? Thanks - Matt