Kernel Project Build

Jan 9, 2012 at 4:33 PM

Hello, I noticed when I build an operating system kernel and try to compile it, it always assumes I want to run in VMWare, which I don't, as it cannot install because of hardware issues, what I would like to know is: Is there a way to change the project settings so it doesn't do anything except build the ISO image?

Jan 9, 2012 at 6:15 PM
LukeTerry wrote:

Hello, I noticed when I build an operating system kernel and try to compile it, it always assumes I want to run in VMWare, which I don't, as it cannot install because of hardware issues, what I would like to know is: Is there a way to change the project settings so it doesn't do anything except build the ISO image?

Yes there is, if you go into your project, and find the green arrow, next to it should be a drop down list saying "Debug", click it and select "Release". Now hit the green button which will now build the project. It will attempt to open VMWare, as I know you don't have it, so Im not sure what it will do, but go into your project folder under Bin > Release. And you will find a ISO. Burn it to a disk or follow my USB boot tutorial here: http://pearos.codeplex.com/wikipage?title=Boot%20By%20usb&referringTitle=Home that method will work with any Cosmos ISO. Yours Truly - Matt

 

If it says "Debug" it will build it to run in VMWare, you want to make sure "Release" is selected so it will run stand alone without VMWare.

Coordinator
Jan 9, 2012 at 8:44 PM
> Hello, I noticed when I build an operating system kernel and try to
> compile it, it always assumes I want to run in VMWare, which I don't, as
> it cannot install because of hardware issues, what I would like to know
> is: Is there a way to change the project settings so it doesn't do
> anything except build the ISO image?

It used to be an option and will again in the future. For now just run
it as VMWare and extract the ISO which it makes to boot vmware.
Developer
Jan 9, 2012 at 9:27 PM

It always will build an ISO. Look in your projects debug folder

On Jan 9, 2012 10:33 AM, "LukeTerry" <notifications@codeplex.com> wrote:

From: LukeTerry

Hello, I noticed when I build an operating system kernel and try to compile it, it always assumes I want to run in VMWare, which I don't, as it cannot install because of hardware issues, what I would like to know is: Is there a way to change the project settings so it doesn't do anything except build the ISO image?

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Coordinator
Jan 9, 2012 at 10:09 PM
> It always will build an ISO. Look in your projects debug folder

In the latest build you can look at the Cosmos output pane for the iso
location during build.
Jan 10, 2012 at 12:09 AM
joshbeitler wrote:

It always will build an ISO. Look in your projects debug folder

On Jan 9, 2012 10:33 AM, "LukeTerry" <notifications@codeplex.com> wrote:

From: LukeTerry

Hello, I noticed when I build an operating system kernel and try to compile it, it always assumes I want to run in VMWare, which I don't, as it cannot install because of hardware issues, what I would like to know is: Is there a way to change the project settings so it doesn't do anything except build the ISO image?

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Be sure your right before you post. Your actually wrong. Yes it does build a ISO into the debug folder, but if you have it selected to debug and grab that iso out of the debug folder, good luck running it outside of VMWare. Because it will only work on build. The release method let's it run outside of the debugging session. The debug method uses a debugger connection, and obvoiusly he doesn't have one. So he needs to use realease to run it in something other than VMWare. Thanks - Matt

Developer
Jan 10, 2012 at 12:20 AM
Edited Jan 10, 2012 at 12:20 AM

Actually, if he has the debug level set to none, it has the same effect, and the ISO is much smaller :P (because it runs my very basic optimizer on it, and removes almost all of the labels that are emitted by default (do enable debugging btw :P), as well as does a few other optimizations on the output, but nothing really significant currently :P)

(Btw, sorry about the double post, something seems to be wrong with my mouse, and I need to fix it :P)

Developer
Jan 10, 2012 at 12:20 AM

Actually, if he has the debug level set to none, it has the same effect, and the ISO is much smaller :P (because it runs my very basic optimizer on it, and removes almost all of the labels that are emitted by default (do enable debugging btw :P), as well as does a few other optimizations on the output, but nothing really significant currently :P)

Jan 10, 2012 at 2:43 AM
blah38621 wrote:

Actually, if he has the debug level set to none, it has the same effect, and the ISO is much smaller :P (because it runs my very basic optimizer on it, and removes almost all of the labels that are emitted by default (do enable debugging btw :P), as well as does a few other optimizations on the output, but nothing really significant currently :P)

Where do you set that at? Cause I dont see it under properties? Thanks - Matt

Developer
Jan 10, 2012 at 1:14 PM

You set it in the 'Debug' tab on the .cosmos project.


~Also, as a note to myself (As this will go into my email log), I need to commit the Project Skipped newline fix.
(if I don't, and I'm talking on the IRC, remind me :P)

Jan 12, 2012 at 6:48 PM

Thanks for the replies, both work, I have set the release properties so it just compiles the ISO, then it doesn't throw an exception every time I build the project. I know this is unrelated, but is there a way to use colours in VGAScreen without setting it in the palette?

Jan 12, 2012 at 6:59 PM
lukeTerry wrote:

Thanks for the replies, both work, I have set the release properties so it just compiles the ISO, then it doesn't throw an exception every time I build the project. I know this is unrelated, but is there a way to use colours in VGAScreen without setting it in the palette?

Yes, if you use VGAScreen.SetTestmode(), it will set all the needed colors for you. Or you can use my method over here: www.pearos.codeplex.com which you are welcome to use.

If you want to use the first method do this:

private Cosmos.Hardware.VGAScreen VGAScreen = new Cosmos.Hardware.VGAScreen();

then use: VGAScreen.SetTestmode();

the only thing about the first method, is you are going to have to figure out what index number goes for what color, but other than that it will work, the second which is my method, we set the colors so, it's not to bad (My opion)

I use the current cosmos source code, so if your not using it already you will need to, to do what I said above. Yours Truly - Matt