This project is read-only.

VMWare runs the old OS instead of my new one.

Mar 7, 2012 at 12:23 AM

When I try and run my OS, it always runs the old command-line version of it. I have deleted all of the code that makes the command-line run and put in GUI code, but it still runs the command-line. Any way to resolve this?

Mar 7, 2012 at 12:57 AM
scifiboi wrote:

When I try and run my OS, it always runs the old command-line version of it. I have deleted all of the code that makes the command-line run and put in GUI code, but it still runs the command-line. Any way to resolve this?

I have had this happen with a program before. Um I believe the way to fix this is to delete the ISO from the release and debug section to force it to make a new one and then make sure you have release selected. Hope it helps - Matt

Mar 7, 2012 at 1:03 AM

Now nothing boots. It says operating system not found. Hey, can you get on skype?

Mar 7, 2012 at 1:28 AM
scifiboi wrote:

Now nothing boots. It says operating system not found. Hey, can you get on skype?

Ok heres what you do. Right click on The Cosmos logo item in the list view. And select run as startup or something close to that. That should solve the problem. Hope it helps - Matt

Mar 7, 2012 at 1:34 AM

Nope, still no OS found.

Mar 7, 2012 at 1:38 AM

Try building the project via build menu then use the start into debugger button on toolbar

On Mar 6, 2012 6:34 PM, "scifiboi" <notifications@codeplex.com> wrote:

From: scifiboi

Nope, still no OS found.

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Mar 7, 2012 at 1:42 AM

I did that, but now it's running the old OS again.

Mar 7, 2012 at 2:21 AM

For some reason, it's not making the ISO. I checked in the bin folder, and there is no ISO.

Mar 7, 2012 at 2:26 AM
I think I know what the problem is. You might have switched from Debug to Release or vis-versa, and it's not set-up to create an .ISO. Right click on the COSMOS project and tell it to use an .ISO.
Mar 7, 2012 at 2:32 AM

Cosmos isn't working because usually there is a message after the build telling how long the build process took, but there isn't one now. Also, the build is taking 3 seconds to complete, and this is a big OS, so it should take a few minutes.

Mar 7, 2012 at 2:36 AM
Oh.
Mar 7, 2012 at 7:58 AM
scifiboi: are you using vs express? if so, you need to build twice (the .csproj file and the .cosmos file).

On Wed, Mar 7, 2012 at 3:36 AM, EagleEyeSA <notifications@codeplex.com> wrote:

From: EagleEyeSA

Oh.

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Mar 7, 2012 at 1:12 PM

No, it's VS Ultimate

Mar 7, 2012 at 1:14 PM
are you using devkit (and cosmos.sln as your solution) ?
pleas ehave a look at the output panel in visual studio: it should give you a clue on what's going on during build..


On Wed, Mar 7, 2012 at 2:12 PM, scifiboi <notifications@codeplex.com> wrote:

From: scifiboi

No, it's VS Ultimate

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Mar 7, 2012 at 11:01 PM

I'm using the devkit, but AxisOS.sln is my solution.

Mar 7, 2012 at 11:05 PM

It's making the AxisOS.dll file, but not the ISO.

Mar 8, 2012 at 2:54 AM
scifiboi wrote:

It's making the AxisOS.dll file, but not the ISO.

Ok try these steps.

Option1, Right click on The Green C# Project name, most likely AxisOs and select build at startup or something close to that. Then hit release and the green arrow and see if that works.

Option2, Right click the Cosmos Icon on the file tree and select build at startup or something close to that. Then hit release and the green arrow.

One of these options will work, I have had this happen to me and one of these fixed it. I am not sure which one but thats for you to find out. Hope it works, - Matt

Mar 8, 2012 at 8:23 AM

Maybe it's the MakeISO tool

-Aurora

Mar 8, 2012 at 8:31 AM
which is why i said look in the debug window. it should print you stuff there and give hints about what goes wrong..


On Thu, Mar 8, 2012 at 9:23 AM, Aurora01 <notifications@codeplex.com> wrote:

From: Aurora01

Maybe it's the MakeISO tool

-Aurora

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Mar 8, 2012 at 2:15 PM

Solved. Thanks for the help. I right clicked on the Cosmos Project and clicked build instead of building the entire solution. Might want to keep this down in your docs if this ever happens to anyone else.

Mar 8, 2012 at 2:17 PM
it means your solution configuration is goofed up. normally it'll set your project to build in all configurations..


On Thu, Mar 8, 2012 at 3:15 PM, scifiboi <notifications@codeplex.com> wrote:

From: scifiboi

Solved. Thanks for the help. I right clicked on the Cosmos Project and clicked build instead of building the entire solution. Might want to keep this down in your docs if this ever happens to anyone else.

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Mar 8, 2012 at 3:22 PM

I don't know what I would have done to screw it up though. I have never gone into the settings of the .Cosmos project before yesterday.