Error occurred while invoking NAsm.

May 20, 2012 at 4:32 PM

Ok, today  was working on "RevolutionOS", and added a little Game to it, then after I finished it, I tried debugging it (I use "Release").


And Then I a few errors:

- Error occurred while invoking NAsm.

- 7 times: RevoluionOSBoot.asm Line: 84987 Code: call System_Int32__System_Int32____Get_System_Int32__System_Int32_

 

I hope somebody could help me :)

Everybody, who helps gets credits :)

Coordinator
May 20, 2012 at 4:45 PM
What Cosmos version you use? Also, how do you plan to debug when using release mode?


On Sun, May 20, 2012 at 6:32 PM, TheKleini666 <notifications@codeplex.com> wrote:

From: TheKleini666

Ok, today was working on "RevolutionOS", and added a little Game to it, then after I finished it, I tried debugging it (I use "Release").


And Then I a few errors:

- Error occurred while invoking NAsm.

- 7 times: RevoluionOSBoot.asm Line: 84987 Code: call System_Int32__System_Int32____Get_System_Int32__System_Int32_

I hope somebody could help me :)

Everybody, who helps gets credits :)

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


May 20, 2012 at 4:54 PM

Civilwarrock told me to use Release, because then the OS works much faster :)

 

I don't know what Version I use :(

Coordinator
May 20, 2012 at 5:01 PM
Debugging wont work in release mode for sure. See the control panel, installed programs to find out what version you have installed..


On Sun, May 20, 2012 at 6:54 PM, TheKleini666 <notifications@codeplex.com> wrote:

From: TheKleini666

Civilwarrock told me to use Release, because then the OS works much faster :)

I don't know what Version I use :(

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


May 20, 2012 at 5:06 PM

Also debugging doenst work ;(

 

And Release works every time ;(

 

I use:

Cosmos71406

Coordinator
May 20, 2012 at 5:19 PM

What I'm saying: in release mode debugging won't work.

Op 20 mei 2012 19:06 schreef "TheKleini666" <notifications@codeplex.com> het volgende:

From: TheKleini666

Also debugging doenst work ;(

And Release works every time ;(

I use:

Cosmos71406

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Developer
May 20, 2012 at 5:27 PM

Your using multi-dimentional arrays. Multi-dimentional arrays are not supported.

May 20, 2012 at 5:51 PM

Yeap I use them for a maze, but thanks for helping :)

 

On Windows my game works perfectly, but now withut multi dimentianol arrays, i have a big problem.

 

Is there no way to use them?

Coordinator
May 20, 2012 at 7:22 PM
On 5/20/2012 1:51 PM, TheKleini666 wrote:
> Yeap I use them for a maze, but thanks for helping :)
>
> On Windows my game works perfectly, but now withut multi dimentianol
> arrays, i have a big problem.
>
> Is there no way to use them?

Use jagged arrays instead.
May 20, 2012 at 7:27 PM
Yea I'll do that, the picture (Background) won't be difficult with jagged Arrays, but the Gameplay is much easisr wirh jagged arrays.

From: kudzu

On 5/20/2012 1:51 PM, TheKleini666 wrote:
> Yeap I use them for a maze, but thanks for helping :)
>
> On Windows my game works perfectly, but now withut multi dimentianol
> arrays, i have a big problem.
>
> Is there no way to use them?

Use jagged arrays instead