Finally....

Jun 23, 2012 at 2:01 AM
Edited Jun 23, 2012 at 2:02 AM

Well after many hours of banging my head up against the wall and tons of reading. I have finally figured out how to edit those files on the VMWare disk that comes with Cosmos and is used when testing your os out of VMWare. Now with this being said, I found some other interesting info. Cosmos, Did you know without that disk the OS wont boot in VMWare? I dont know why. Is this the reason why the OS wont boot on live Hardware either? Cause it does the same thing the live boot does just without the Kernel exception error.... Why is this? And can you guys fix it? Cause right now without Cosmos being installed you cant boot the OS Iso. Which is kind of odd. But oh well.

 

Ok now right to it! I am going to share with you a small in depth tutorial as well as I can. Let me know what you think.

So, first things first. We need to get a program! I don't think you need VMWare installed for this and you don't NEED workstation either, as I don't have it myself.

#1 Download And Install this: http://www.vmware.com/download/eula/diskmount_ws_v55.html

#2 Ok now the fun part! Goto Run and type without quotes "%appdata%" now it should have already taking you into the roaming folder, or another one. You'll know because you will see a "Cosmos User Kit" folder, something close to that.

#3 Go into the build folder and navigate to "VMWare" and then"Workstation". Find the file "Filesystem.vmdk" its the filesystem that Cosmos stored some files in. Now get its path, example "C:/Documments ect.... and \Filesystem.vmdk" now get the full path including that file.

#4 Now goto your computer under "C:" and navagate to Program Files and Program Files x86 if your using Windows7 ect.. Now once inside find the folder "VMWare" now go inside and find the folder "VMware DiskMount Utility" Now. Get the path. It will be under the explorer bar if you have vista or above just click it and it will give you the path. Now do a control c.

#5 Open CMD and type without quotes "cd " and then right click and hit paste. Hit the enter key. Now this is where things get tricky.

#6 type without quotes into your cmd window "vmware-mount " then type the drive number, this can be anything, so for me it would be "vmwar -mount J: " without quotes. Now after that you need to copy the full path including the file of the "Filesystem.vmdk" in the Cosmos directory we were just in. Once copied do step # 7.

#7 now you should already have in the cmd window without quotes "vmware-mount J: " now do type " and the right click and hit paste to paste the full path of the "Filesystem.vmdk" file. Now type ". Ok now it the enter key. The Command will look something like this vmware-mount J: "path"

#8 Now it should say like error the virtual machine is suspended. Ok if you get this dont worry. Simply open VMWare click the Cosmos os button. Let it resume it, then hit power down, under a menu, cant remeber which. Its easy to find. Now once the OS has been powered down, try #6 & #7 again to get the command. Try the command and it should say nothing.

#9 Now since you didn't get the error this time, your most likely thinking... "Um it didn't say anything". I know and that's good =)". Now in the same cmd window type the drive letter you put example "J:" now hit enter. It will then goto the J drive instead of the one we cd'd to. Now we get to have the fun part.

#10. Ok heres the bad and good part. Bad part, theres no GUI for this. Good part its easy to work without one, maybe I will make a program for this...

Ok so now type in the same cmd window without quotes "dir" and hit enter, this will list all the files on the mounted virtual drive. Now heres the few commands we will work with, if you need info on them, feel free to type "help" without quotes in the cmd window. 

Ok to add a file we can type "copy filepath" without quotes, that will copy the specified file to the virtual disk. Now you can type "del filename" to delete a file from the virtual disk as well.

and I believe move will allow you to move a file to it, and move can also take a file out of the virtual disk as well. Now once your done editing, you will need to unmount the virtual disk.

#11 Do step #4 & #5 again to cd to the virtual disk utility path. Now type without quotes "vmware-mount J: /d" to umount the disk! Now you can replace J: with the drive you specified, just J was a random one I decided to use. Now you have successfully modify'ed your Cosmos Virtual Disk! Now guys, you can add in files and load images, fonts, programs ect... Wohoo! Enjoy and let me know what you think. I hope I wrote this well.. =)

Developer
Jun 23, 2012 at 10:45 AM

You forgot to mention that this methods won't work on 64-bit machines (All new ones)

Jun 24, 2012 at 4:34 PM
CMan332 wrote:

You forgot to mention that this methods won't work on 64-bit machines (All new ones)

Hmm yeah forgot that thanks CMan332. But you could still run it on 64bit as there is a x86 legacy thing, so that you can still run x86 programs, so I still think it would work, but I am not sure yet. Ill try it. Thanks - Matt

Developer
Jun 24, 2012 at 9:40 PM

It tries to install a 32-bit driver. Already tried it myself on my 64-bit machine haha.

Jun 25, 2012 at 6:42 AM
CMan332 wrote:

It tries to install a 32-bit driver. Already tried it myself on my 64-bit machine haha.

Darn, you stole all the fun. =). Oh well. - Matt

Jun 27, 2012 at 11:21 AM
Or you could (if on windows which I assume everyone is ) go to the start menu and search for hard disk". Then select "create and format hard disk partions".Open that then go to the menu bar and select "action>create vhd" then select an appropriate disk size and a location where it will be made (it doesn't really matter though just use your documents folder) (if your on windows 8 like me then just select vhd not vhdx file type). After your vhd is created go to the vmware> cosmos virtual machine > settings then attach the vhd as a virtual hard disk. ;)

On Tue, Jun 26, 2012 at 6:13 AM, civilwarrock <notifications@codeplex.com> wrote:

From: civilwarrock

CMan332 wrote:

It tries to install a 32-bit driver. Already tried it myself on my 64-bit machine haha.

Darn, you stole all the fun. =). Oh well. - Matt

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com




--
---------------------------
Jacksen Kline
Super Byte

Apr 5, 2013 at 12:11 PM
To fix the ISO booting on real hardware, I used the uncompiled .asm file that cosmos outputs and compile that myself using a few scripts and works like a charm :D
Coordinator
Apr 5, 2013 at 12:18 PM
what do the few scripts do? ie, what do we do wrong?



Apr 5, 2013 at 3:04 PM
My scripts are very personalized to my laptop, but it essentially grabs the .asm file that cosmos produces, then it uses NASM to compile it to the .bin then it adds it to a .iso with isolinux (isolinux.cfg AND syslinux.cfg)

I'll make a version that would work on anyone's computer.
Coordinator
Apr 5, 2013 at 3:06 PM
Can you see if it also works with ELF?
It must be something small that's not working. Maybe even related to addresses....



Developer
Apr 5, 2013 at 3:09 PM
Uniq, What is the problem with cosmos iso.... Can you tell us in detail...
And how you burn the ISO to disc
Because i don't find any reason that it wouldn't work... :p
Apr 5, 2013 at 3:30 PM
Well, for me, it says that it's not a valid COM32R image whilst booting. Then when manually trying to get it to boot, it says that the Kernel is invalid or corrupt. The ISO that Cosmos produces doesn't work with 7zip so consequently doesn't work with Universal USB Installer. (The same thing happens on CD).

I personally don't see how your way of doing it doesn't work, but I've spent a long time trying to get UniqOS to boot on real hardware so I decided the best thing to do was to create a few scripts that I could debug. First attempt and it worked just fine.

Here's a download to the scripts I used. Read the READ_ME.txt for instructions.

(License for NASM is included. Don't think there is one for isolinux.)

Here's a download for the UniqOsBoot.iso that Cosmos generated: http://thecodeverse.org/downloads/see/cosmos/UniqOsBoot.iso

Here's a download for the UniqOsBoot.iso that my script generated: http://thecodeverse.org/downloads/see/uniqos/UniqOsBoot.iso

And finally, here's the download for the scripts: http://thecodeverse.org/downloads/see/uniqos/UNIQOS_KERNEL.zip

Just for some information, I'm running Windows 7 32BIT, my account is Administrator. Using Visual Studio 2010 Professional. Settings set to release mode: ISO as VMWare hates my machine.
Apr 5, 2013 at 3:31 PM
Oh and I used Universal USB Installer for USB booting and the built in Windows ISO burner for CD.
Coordinator
Apr 5, 2013 at 3:37 PM
Cosmos doesn't produce a COM32R image. the mboot.c32 is a com image (com32r)


Apr 5, 2013 at 3:39 PM
That's what confused me.... still, the .iso that Cosmos produces doesn't boot.
Coordinator
Apr 5, 2013 at 3:44 PM
what error do you get? you get a syslinux/isolinux boot prompt?



Apr 5, 2013 at 3:49 PM
Coordinator
Apr 5, 2013 at 3:50 PM
OK. so the problem is not withou our output.bin but with the mboot.c32...



Apr 5, 2013 at 3:52 PM
Yup, you can use the mboot.c32 from my script if you wish :)
Coordinator
Apr 5, 2013 at 4:13 PM
is it an official one?


Apr 6, 2013 at 12:24 AM
I believe so



Apr 6, 2013 at 1:12 AM
oh my god. what is up with people here digging up ancient threads? Couldn't you have just created a new one?
Apr 6, 2013 at 10:32 AM
I have no idea why I didn't create a new thread...


Developer
Apr 6, 2013 at 1:33 PM
Use of old thread, doesn't matter...
Apr 6, 2013 at 3:57 PM
Yeah it does you necroposter