This project is read-only.

Builds

Topics: Installation
Aug 19, 2012 at 1:10 PM

Which version of COSMOS actually builds properly and doesn't throw random errors, because the latest one doesn't compile, it keeps throwing "Setup didn't start".

Aug 21, 2012 at 8:14 PM

If I run the setup manually, it then throws this when trying to build a project:

Error 1 The type initializer for 'Cosmos.Build.Common.CosmosPaths' threw an exception.   at Cosmos.Build.MSBuild.IL2CPUTask.CheckFirstTime() in e:\Users\Luke\Downloads\source2\Build\Cosmos.Build.MSBuild\IL2CPUTask.cs:line 58   at Cosmos.Build.MSBuild.IL2CPUTask.Initialize() in e:\Users\Luke\Downloads\source2\Build\Cosmos.Build.MSBuild\IL2CPUTask.cs:line 140   at Cosmos.Build.MSBuild.IL2CPUTask.Execute() in e:\Users\Luke\Downloads\source2\Build\Cosmos.Build.MSBuild\IL2CPUTask.cs:line 189 E:\Program Files\MSBuild\Cosmos\Cosmos.targets 30 6 CosmosKernel1Boot

Aug 21, 2012 at 10:08 PM
On 22/08/12 06:36, LukeTerry wrote:

From: LukeTerry

Which version of COSMOS actually builds properly and doesn't throw random errors, because the latest one doesn't compile, it keeps throwing "Setup didn't start".

Go find the output exe. That will install it
Aug 21, 2012 at 10:37 PM

I ran the output exe, now it throws the error above in visual studio when building 

Aug 21, 2012 at 10:54 PM
On 8/21/2012 5:06 PM, LukeTerry wrote:
> Which version of COSMOS actually builds properly and doesn't throw
> random errors, because the latest one doesn't compile, it keeps throwing
> "Setup didn't start".

Did you change your Cosmos path recently?
Aug 21, 2012 at 11:23 PM

Being the place I build it from? Yes, I moved it to a secondary hard disk.

Aug 22, 2012 at 3:20 AM
On 8/21/2012 6:23 PM, LukeTerry wrote:
> Being the place I build it from? Yes, I moved it to a secondary hard disk.

Delete the Cosmos Build task in Windows Scheudler, then rerun build.