Virtual Machine trouble.

Topics: Compiler, Installation, Using Cosmos (Developing your own OS, projects, etc)
Sep 30, 2012 at 4:22 PM

I have a mac. I use vmware fusion, but my trial expired. VirtualBox can't run vmware player. My os uses. Vmware svga, so i can not run it in virtualbox. Is there any free solution?

Coordinator
Sep 30, 2012 at 4:25 PM
On 9/30/2012 12:22 PM, jpal wrote:
> I have a mac. I use vmware fusion, but my trial expired. VirtualBox
> can't run vmware player. My os uses. Vmware svga, so i can not run it in
> virtualbox. Is there any free solution?

Bochs will probably run in VMware.
Coordinator
Sep 30, 2012 at 4:25 PM

Try bochs. If I recall correctly, they allow using VMware adapter.......
Not sure how mature our bochs support is though....

Op 30 sep. 2012 18:22 schreef "jpal" <notifications@codeplex.com> het volgende:

From: jpal

I have a mac. I use vmware fusion, but my trial expired. VirtualBox can't run vmware player. My os uses. Vmware svga, so i can not run it in virtualbox. Is there any free solution?

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Sep 30, 2012 at 4:30 PM

thanks.

Sep 30, 2012 at 9:35 PM

Well, i get a error: no bootable device.

Oct 1, 2012 at 12:24 AM

Is the ISO mounted? Also make sure the mounted drive is in the boot queue. 

Oct 1, 2012 at 6:54 AM

Not to thread jack but I also am using a mac, I run windows 7 with vmware fusion. When I try to debug cosmos the vmware player it goes unresponsive and whe I try to close it says virtual machine is busy.

Coordinator
Oct 1, 2012 at 7:56 AM
Huh? nested vm's?


On Mon, Oct 1, 2012 at 8:54 AM, MichaelQuint <notifications@codeplex.com> wrote:

From: MichaelQuint

Not to thread jack but I also am using a mac, I run windows 7 with vmware fusion. When I try to debug cosmos the vmware player it goes unresponsive and whe I try to close it says virtual machine is busy.

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Oct 1, 2012 at 3:06 PM

Yeah nested vms

Coordinator
Oct 1, 2012 at 3:08 PM
probably some issue with your hardware then, and it not being able to passthrough the virtualization stuf.f.


On Mon, Oct 1, 2012 at 5:06 PM, MichaelQuint <notifications@codeplex.com> wrote:

From: MichaelQuint

Yeah nested vms

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Oct 1, 2012 at 5:58 PM

yeah if I manually make the vm with the cosmos build image it works fine.

Developer
Oct 1, 2012 at 11:58 PM

I have only got it to work using side by side vms

On Oct 2, 2012 3:28 AM, "MichaelQuint" <notifications@codeplex.com> wrote:

From: MichaelQuint

yeah if I manually make the vm with the cosmos build image it works fine.

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Oct 2, 2012 at 3:24 AM

so how exactly does bochs work?

Coordinator
Oct 2, 2012 at 7:11 AM
Not sure, maybe BlueSkeye can join in this discussion..

I think you'll need to install bochs and then specify in the project settings..


On Tue, Oct 2, 2012 at 5:25 AM, jpal <notifications@codeplex.com> wrote:

From: jpal

so how exactly does bochs work?

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Developer
Oct 2, 2012 at 7:47 AM
jpal wrote:

so how exactly does bochs work?

Bochs program doesn't use any hardware related virtualization technology. It's a pure emulation engine. So I feel there is no problem with Bochs running in an already virtualized environment. Obviously you must have installed the Bochs package. All tests we performed so far where done with version 2.6 (the latest). Previous version (2.5) is probably fine also however not officially supported by Cosmos.

The Bochs program has a -f command line argument that let you provide the emulator with a configuration file. Starting with changeset #95808 you will notice that each time you create a Cosmos project a "Cosmos.bxrc" file is automatically added to your project. This is the configuration file that will be provided to Bochs when we launch it at debugger startup (provided you choose Bochs as the execution engine in the project properties "Profile" pane). You can modify the configuration file to make it fit your needs. The file will be copied in the output directory during project compilation. However you must not change the ata0 and ata0-master lines. This is where we tell Bochs to boot from a CDROM with an inserted disk backed by an ISO file matching the project name. This file is automatically constructed at debugging session start from the content of the .bin file that comes from your project compilation. You must not change the com1 port definition either. This is used for communication between Bochs and the Visual Studio debugging engine.

If you already created a Cosmos project before the above mentioned changeset, I strongly suggest you recreate a new one. Otherwise you can try to keep your old project and manually add a Cosmos.bxrc configuration file in your project and make sure the associated Build Action is set to "Content".

Oct 2, 2012 at 12:24 PM

I use the latest release, not the devbuilds.

Coordinator
Oct 2, 2012 at 12:34 PM
Bochs is not in the release yet..


On Tue, Oct 2, 2012 at 2:24 PM, jpal <notifications@codeplex.com> wrote:

From: jpal

I use the latest release, not the devbuilds.

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com