This project is read-only.

No kernel found!

Topics: Using Cosmos (Developing your own OS, projects, etc)
Dec 12, 2012 at 2:08 AM

Hey all, I am new to Cosmos and I am having this error: No kernel found! It only appears when I save the project and when I release it, because when I use debug, it wont work. Also, how can I change the processors architecture, when I go in the config manager, even if I set the bootstrap to x86, I close it and when I reopen it, it it still set at Any CPU. Please help me asap, I have an os to do!

Dec 12, 2012 at 7:43 AM
Are you using the devkit or the userkit?


On Wed, Dec 12, 2012 at 3:08 AM, james222 <notifications@codeplex.com> wrote:

From: james222

Hey all, I am new to Cosmos and I am having this error: No kernel found! It only appears when I save the project and when I release it, because when I use debug, it wont work. Also, how can I change the processors architecture, when I go in the config manager, even if I set the bootstrap to x86, I close it and when I reopen it, it it still set at Any CPU. Please help me asap, I have an os to do!

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com


Dec 12, 2012 at 12:41 PM
Edited Dec 12, 2012 at 12:43 PM

james222 , lets say your startup project name is CKTBoot

To solve it simply go to references under  CKTBoot remove the reference CKT from references(It should be the one displaying a yellow warning sign next to it", then right click  Reference folder and select Add Reference. Visual Studio Should have a Tab Named "Projects" Open select the project displayed and click "OK". I have tried it on both kits it should work fine.

Dec 12, 2012 at 5:03 PM
Before talking about specific solutions, let assure what he's using: devkit or userkit.
He's talking about Bootstrap configuration, which is devkit only..


On Wed, Dec 12, 2012 at 1:41 PM, forest201 <notifications@codeplex.com> wrote:

From: forest201

Lets say your startup project name is CKTBoot

To solve it simply go to references under CKTBoot remove the reference CKT from references(It should be the one displaying a yellow warning sign next to it", then right click Reference folder and select Add Reference. Visual Studio Should have a Tab Named "Projects" Open select the project displayed and click "OK". I have tried it on both kits it should work fine.

Read the full discussion online.

To add a post to this discussion, reply to this email (Cosmos@discussions.codeplex.com)

To start a new discussion for this project, email Cosmos@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com