This project is read-only.

Cosmos Background TextScreen

Topics: Using Cosmos (Developing your own OS, projects, etc)
Jul 7, 2013 at 11:40 AM
Hi everyone. I'm using Cosmos UserKit92560 and Visual Studio 2010. I was wondering if there's any way to set a background color for the screen in TextScreen mode Without Blinking. Also is there any way that I could set a Font Size or Font Family for Texts?
Jul 7, 2013 at 12:21 PM
Edited Jul 7, 2013 at 12:43 PM
Hey hydarnes.

I had this problem too.
I think the Textscreen is bad programmed and they are setting the "blinking bit" accidentally..

A solution would be to write your own Console.
You can find very much informations about this at Text UI

You can also look here: Textausgabe
It is in german, but it should be easy to understand and it offers more informations than the english one above,

Setting the Font Size / Font Family is a problem that cannot be fixed without using a virtual Console.
You'll need to write your own graphics driver and use this driver to display the text.

I hope my comment helps you
Jul 7, 2013 at 1:42 PM
Could you explain more about how to create my own console.
Jul 16, 2013 at 9:34 PM
         Console.BackgroundColor = ConsoleColor.Blue;
        Console.ForegroundColor = ConsoleColor.DarkCyan;
Jul 17, 2013 at 7:29 AM
Edited Jul 17, 2013 at 7:30 AM
I explained this to you last time you asked this question. You need to set the blink attribute to 0. In RAM video memory is represented as such

Bit 76543210
|||||^^^-fore colour
||||^----fore colour bright bit
|^^^-----back colour
^--------back colour bright bit OR enables blinking Text
By using a bright color, you are setting the bright bit, which is also used by some video cards to produce blinking text. You must stick to either dark colors or use a custom color palate. If you read the article on OSDev Wiki, you will have all of the information you need.
Jul 17, 2013 at 2:09 PM
Yes you did, But how? I don't understand how to set the blink attribute to 0 ...???