This project is read-only.

VS2013 Compatibility

Topics: Developing Cosmos (Working on Cosmos source code directly), Installation, Using Cosmos (Developing your own OS, projects, etc)
Oct 31, 2013 at 10:12 PM
Hi all,

Just a heads up that I have been working on getting Cosmos and the user-kit & dev-kit installer working in VS2013. I have literally just succeeded in installing the user-kit, creating a project in VS2013 and running it in VMWare player.

I will try and clean-up what I have done to submit a patch (or temp. alternative release) and also a set of installation instructions (which seem to be missing from Cosmos). These will include VS2013 pre-requisites, download urls and all necessary hacks to get it to work properly as I haven't managed fully automate the installation.

Check back in a few days / a week for more info.
Ed
(So excited right now!)
Oct 31, 2013 at 10:15 PM
Oh by the way, I have achieved this with the last Beta release (103291) not the latest checked-in source. I see no reason why merging source-code between versions will be an issue though since the only changes are to the installers and project files not the source code.
Oct 31, 2013 at 11:55 PM

Awesome!

Are you on the mailinglist? We can give you source access.

We do have instructions on how to install Cosmos userkit but most users don't read too well.... :-)

All steps, besides the shell should be done by the installer..

Op 31 okt. 2013 22:15 schreef "EdwardNutting" <[email removed]>:

From: EdwardNutting

Oh by the way, I have achieved this with the last Beta release (103291) not the latest checked-in source. I see no reason why merging source-code between versions will be an issue though since the only changes are to the installers and project files not the source code.

Read the full discussion online.

To add a post to this discussion, reply to this email ([email removed])

To start a new discussion for this project, email [email removed]

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Nov 1, 2013 at 12:19 AM
Not yet - I wanted to get my teeth into this before committing to joining mailing list etc. Getting source access would be good.

I have seen your instructions (and tried following them twice) but they failed me...so then I decided to port it to VS2013. Also, when I said missing, what I sort of meant was the pre-requisite software doesn't seem to be listed (e.g. Inno, VS SDK etc.). My instructions will initially include a few setup hacks and fixes that I haven't been able to iron out.

I'm planning on writing a CodeProject article on this but how would you like me to publish my current version the source? Can I put it with the article? (Is that allowed by the license? I haven't checked yet...) After that I'll join the mailing list and if you'd like, attempt to merge my changes with the source. (I did download the latest available CodePlex source but it appears to be broken - I seem to remember something like an HMI class reference was missing for Heap.cs so compiling failed.)
Nov 1, 2013 at 9:09 AM
Ah, the innosetup, VS SDK etc instructions are available on the mailinglist.. the Userkit only needs VS SHell.. Go join the mailinglist, We can help you with lots ot things there.. We'd really like you to merge the changes first (ask me/others to help
you...), and then do whatever you want (maybe document it on the codeplex site, or so..). Publishing your work is allowed by the license, but it would most likely mean many users abandon the original cosmos sources.. :) I'll try to see what's wrong with the
current sources (from a compilation point of view) later today.. 2013/11/1 EdwardNutting <[email removed]>:
Nov 1, 2013 at 2:42 PM
Okay sure I'd be happy to try and merge and then document it here on CP. At the moment my changes are pretty brute force though and there are various issues so I'm not sure that merging yet is the best idea. I'll join the mailing list and discuss it more there.
Nov 1, 2013 at 2:44 PM
Be sure to ask a lot: no problem when doing so: we have lots of (hidden?) knowledge about everything.. :) 2013/11/1 EdwardNutting <[email removed]>:
Nov 1, 2013 at 3:04 PM
Will do :) I went onto Yahoo, signed up etc. and then tried to click "Join Group" (I expected this to put in some form of request to join since the group is private) but Yahoo just pops up a message saying an error occurred (no more info than that). I also sent an email to the Subscribe address. To get source access do I need to "Request to join" the CodePlex project?

Thanks for all your help, Ed
Nov 1, 2013 at 3:06 PM
WHen you sent a mewssage to the cosmos-dev-subscribe at yahoo dot com address, I'll get a message in a couple minutes (or sometimes more.....). I'll approve you. (We have a private list to keep spam out) Once you're in, send a message to the list (send
to cosmos-dev at yah...) with a short into (and any Q's you might already have, etc) and list your codeplex id and I'll add you to the project. Once you have source access, please do discuss before checking in things.. :) 2013/11/1 EdwardNutting <[email removed]>:
Nov 1, 2013 at 3:17 PM
Okay sure thanks - makes sense. And yes I understand the check-in/review thing. I notice you use TFS so do you use code reviews? Or just discuss shelve-sets in the Yah group?
Nov 1, 2013 at 3:19 PM
normally we don't do checkin/review, only in the beginning. This isn't a trust issue, but cosmos is a complex project, easy to screw-up... :) We normally do shelvesets or teamviewer sessions.. 2013/11/1 EdwardNutting <[email removed]>:
Nov 1, 2013 at 3:21 PM
Okay, makes sense :) And what is Teamviewer? Not come across that before... (http://www.teamviewer.com/en/index.aspx ?)
Nov 1, 2013 at 3:23 PM
Yes. It's a tool to do remote-assistance/screen-sharing.. 2013/11/1 EdwardNutting <[email removed]>:
Nov 1, 2013 at 4:26 PM
Not sure what on earth Yahoo is doing..sorry if you receive a second membership request but hopefully the second might work properly? When I tried to send an email to cosmos-dev@yah... it replied saying message undelivered because my email address was not part of the group.I'll try again now (I've just received a second (very different) "Membership approved" message :) )
Nov 1, 2013 at 4:28 PM
I just replied to the membership aproval message.. :) 2013/11/1 EdwardNutting <[email removed]>: